SP 2013 won't expand

Aug 4, 2014 at 1:23 PM
I've got the latest version deployed on SP 2013 and the + boxes won't expand to show sub sites on Google Chrome any idea why?

Also when i use IE9 i get a red cross over the + boxes which fail to work too.

Thanks
Aug 4, 2014 at 3:07 PM
Not sure if it's relevant or not but we are using HTTPS on the sharepoint 2013 farm. The above still applies with the icons and I'm unable to expand the sites to see subsites at any level as the + boxes aren't working/being displayed

Thanks
Coordinator
Aug 5, 2014 at 2:17 PM
Hi Matt,

Can you please let me know how did you install the WSP package?

Can you try to use the compatibility version flag, set to all (so files will be installed on 14 and 15)?

One last thing, can you browse the page with fiddler open and let me know if there are any files missing?

Thanks!
Aug 5, 2014 at 3:10 PM
Hi Shai

I've just retracted the previous solution and added again then did an install using the following syntax;

install-spsolution -identity sitenavigationtree2010package2013.wsp -AllWebApplications -GACDeployment -CompatibilityLevel All

But the web part is still showing red crosses over the + image boxes which still won't allow me to expand sub sites.

I have just run a fiddler trace and it isn't returning an image results, just Tunnel To under the Host column. But if I browseto our live sp 2010 intranet page i get all kinds of results back like images etc - so in short it looks like it isn't picking up any images at on my sp2013 site?

Thanks
Aug 5, 2014 at 3:19 PM
Actually I had to decrypt the fiddler traffic as my web app is https

Here's a couple of screenshots if it helps at all

Image

Image
Coordinator
Aug 6, 2014 at 1:15 PM
Interesting...

See, I have embedded the resources in the web part DLL so it makes a request to itself in order to get these resources.

It's a very old trick (since this is a very old web part) that I used, but for some reason it is returning 401 on your environment.

401 is not "file not found", its "unauthorized".

For some reason, these requests get cancelled on unauthorized. Can you try to open that link in your browser and see if you get the image?
Just visit your page where the web part is at, and add this to the query string: "?TreeControlResource=minus.gif"

Let me know what you get.

Can you also tell me if you are using anonymous user, or a signed in user? what is the authentication used on that site? and what browser are you using?
Aug 6, 2014 at 3:24 PM
When i add to the query string so it's like- https://intranet2013.domain.co.uk/group/sitename/default.aspx?TreeControlResource=blank.gif IE prompts me to open/save default.aspx, i thought the page would just display only the small image icon?

If i click open it throws me into sharepoint designer and a warning about opening a site first etc

I'm logged on as my own domain user account which has full site rights, the web app authentication provider is Default Zone and claims based auth. The User Policy for the web app has full read set for <domain\domain users>

I was thinking could this be an issue if a feature or number of features aren't enabled at the site collection level?

If i allow the default.aspx to open in SPD it just shows me "GIF89a" on the page

Thanks again
Aug 7, 2014 at 2:02 PM
Have you got the dll name so i can check the gac? As it's on win server 2012 it might not have deployed correctly? Seeing as you can't drag and drop files into the gac on 2012 anymore.
Aug 19, 2014 at 7:29 AM
Hi Shai

Just wondered if you have had a chance to take a look into this at all?

Thanks
Coordinator
Aug 26, 2014 at 1:49 PM
This issue might need a fix, I'm sorry I am currently overwhelmed with work.

I can get to it later, but if you / another developer would like to jump in and make the fix it should not be too difficult:
  1. move the embedded resources that are currently in the DLL into the layouts folder
  2. change the src references to use them in the new location
that's all there is to it.

I will try to find the time to handle it soon, but i can make no promises. How urgent is it for you?
Aug 26, 2014 at 3:03 PM
Hi Shai

To be honest I need it in the next week but appreciate you are busy with most likely real deadlines etc. I'll see if a developer here can do it - is it a case of downloading the source code and somehow packaging it up when edited? Unfortunately I'm not a developer so haven't got a clue.

thanks
Matt
Sep 5, 2014 at 8:02 AM
We haven't manaegd to find anyone who can do this yet so if you do get a chance to make the change I'd greatly appreciate.
Coordinator
Sep 8, 2014 at 4:17 PM
Sure i can do it today, i got some time.
Stay tuned...
Coordinator
Sep 8, 2014 at 4:29 PM
Ok, I can make a quick fix and move all embedded resource to "/_layouts/ssnt/" but it will take some time...

instead, could you give me access to your environment so that i can investigate why the current build is not working properly? perhaps a fix to that is easier to do.
Coordinator
Sep 8, 2014 at 4:44 PM
LOL I think i found the issue...

I will be posting a fix soon, some silly JS error I used IE only script in one place...
Coordinator
Sep 8, 2014 at 6:18 PM
Hi Matt, hope you are still with me :)

I uploaded version 1.0.09 with a fix that now works on fire fox, chrome, IE.

Let me know if it works for you!

(Make sure you clear browser cache)
Sep 9, 2014 at 8:04 AM
Hi Shai

I retracted the previous version and deployed the new, but unfortunately still have the exact same problem.

The collapse/expand boxes have a red cross over them - any other ideas? I could do a remote session with you if you have access to a webex type system?

I've done ctrl+f5 in IE, also doesn't work in chrome but IE is the company preference for browser
Sep 9, 2014 at 8:16 AM
Just to update, chrome will display the + boxes but won't let me expand them to see sub sites
Sep 9, 2014 at 8:19 AM
If I change the 'Number or expanded levels' between 0, 1 and 2 it shows sub sites but the ability to click the + and - boxes is disabled if that helps you out?
Sep 9, 2014 at 8:36 AM
Just tried another retract and then a new deploy via powershell

add-SPSolution "c:\deploy\sitenavigationtree 2010 package1109.wsp"
Install-SPSolution -Identity "sitenavigationtree 2010 package1109.wsp" -AllWebApplications -GACDeployment -Compatibilitylevel {14,15}

The content files now appear in the 15 hive on my app server but the webpart doesn't work as above still.
Sep 9, 2014 at 8:59 AM
Just sent you a connection invite on LinkedIn if you wanted to arrange the session across there :)
Sep 10, 2014 at 10:46 AM
Hi Shai

A developer here has looked at the webpart and is saying that the underlying code isn't operating as expected to allow the + boxes to expand even though the image for the + box isn't being displayed so perhaps there is 2 issues?

I've got the following screenshot which may help you see what's going on.

For info - this webpart still works fine in SP2010 just not SP2013 and I have deployed for compatibility levels 14 and 15.

Image
Coordinator
Sep 10, 2014 at 4:18 PM
funny, could you send me a fiddler report of what happens when you open the page, and when you click one of the + icons?
also, if you could give me a URL to browse to with a login I could try to log in there and see if i can reproduce...
Sep 10, 2014 at 4:43 PM
I've got a file could you post an email address for me to mail it to please? Have you tried the tree on SP2013 at all yet? I'm still getting a 401 - i wonder if the tree needs to be adjusted to work over HTTPS? Or maybe a service account running sharepoint hasn't got access to the directory where the images are?

When i click the red crosses with fiddler running it doesn't register any activity. We haven't got a remote session connection here for you to view the screen unless you have your own provider? I may be able to get a free one on team view or something similar, thanks
Sep 10, 2014 at 5:06 PM
Just tried the tree out on a brand new web app that only uses HTTP and got the same experience so it can't be anything to do with the security layer in that regard
Coordinator
Sep 11, 2014 at 12:54 PM
hi,
yah works on my 2013 with https

there should be a request to your page with ? asking for a tree control resource load in the query string in fiddler, this should load the script that loads the objects you are missing.
This is why i wanted to see the fiddler report on that, see what your server returns instead of the script file.

my email is shai at kwizcom dot com if you want you can send it to me there
Sep 11, 2014 at 1:19 PM
Ok thanks - I've just emailed the trace file for investigation :)
Sep 29, 2014 at 10:23 AM
Hi Shai

Just wondering if you have been abl to investigate any further?

Thanks
Coordinator
Dec 24, 2014 at 5:34 PM
Hi Matt,

Please try to use the new version 1.0.10 of this web part, just uploaded to the site. Let me know if it works better, created it especially for SP2013.
You should uninstall the other version since you won't need it anymore.

Thanks.